Map PSU Space Utility for Mac OS X

Below are the software tools which allow you to mount either your Penn State Access Account Storage Space (PASS) or the CLC managed U-Drive network storage.

System Requirements

  • To connect to the UDrive, you must be running Mac OS X 10.6 or higher as of August 22, 2011.
  • You must use a VPN client to connect to PASS or UDrive when using a third-party Internet Service Provider (ISP) or when using a Penn State campus wireless connection.

Install the VPN Client

Map PSU Space Tools

  • For Mac OS X 10.10 and higher, download the current scripts installer here:
  • For Mac OS X 10.6 and higher, download the current scripts installer here:
  • For Mac OS X 10.5 and earlier, download the legacy scripts installer here:

Advanced Users (Optional)

Content Tagging: 

Last Updated August 18, 2017